summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2003-01-21 10:14:41 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2003-01-21 10:14:41 (GMT)
commitdfc33fd8db811feea2bfb974e9da3ed7aea4b10d (patch)
treef087488e9d89546778edc3000e884f63942294ac /configure.in
parent2da75faa871a1f8b7389c41319e1a1d3926b9852 (diff)
downloadcpython-dfc33fd8db811feea2bfb974e9da3ed7aea4b10d.zip
cpython-dfc33fd8db811feea2bfb974e9da3ed7aea4b10d.tar.gz
cpython-dfc33fd8db811feea2bfb974e9da3ed7aea4b10d.tar.bz2
Don't use Posix semaphores on Solaris 8. Fixes #662787.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c8ba86b..8011c97 100644
--- a/configure.in
+++ b/configure.in
@@ -1447,6 +1447,12 @@ pthread_create (NULL, NULL, start_routine, NULL)], [
and your system does not define that.])
fi
+ # Bug 662787: Using semaphores causes unexplicable hangs on Solaris 8.
+ case $ac_sys_system/$ac_sys_release in
+ SunOS/5.8) AC_DEFINE(HAVE_BROKEN_POSIX_SEMAPHORES, 1,
+ Define if the Posix semaphores do not work on your system);;
+ esac
+
AC_MSG_CHECKING(if PTHREAD_SCOPE_SYSTEM is supported)
AC_CACHE_VAL(ac_cv_pthread_system_supported,
[AC_TRY_RUN([#include <pthread.h>