summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2003-05-03 10:12:45 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2003-05-03 10:12:45 (GMT)
commite941617671ece6ee7d4e1ad981d5499b03827f9a (patch)
treefced444089cb235139a7ccb6129f58dc65a85846 /configure.in
parente6bbb4d16f32e4d243897f25b0ad01f81498e095 (diff)
downloadcpython-e941617671ece6ee7d4e1ad981d5499b03827f9a.zip
cpython-e941617671ece6ee7d4e1ad981d5499b03827f9a.tar.gz
cpython-e941617671ece6ee7d4e1ad981d5499b03827f9a.tar.bz2
Patch #724588: Check whether the address of hstrerror and inet_pton can
be taken, and define NI_MAX{HOST|SERV} if necessary.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in36
1 files changed, 35 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 0638b15..765e8bf 100644
--- a/configure.in
+++ b/configure.in
@@ -1857,7 +1857,7 @@ AC_CHECK_FUNCS(alarm chown clock confstr ctermid execv \
fchdir fork fsync fdatasync fpathconf ftime ftruncate \
gai_strerror getgroups getlogin getloadavg getpeername getpgid getpid \
getpriority getpwent getwd \
- hstrerror inet_aton inet_pton kill killpg lchown lstat mkfifo mknod mktime \
+ kill killpg lchown lstat mkfifo mknod mktime \
mremap nice pathconf pause plock poll pthread_init \
putenv readlink realpath \
select setegid seteuid setgid \
@@ -1923,6 +1923,40 @@ AC_TRY_COMPILE([
AC_MSG_RESULT(no)
)
+AC_MSG_CHECKING(for hstrerror)
+AC_TRY_COMPILE([
+#include "confdefs.h"
+#include <netdb.h>
+], void* p = hstrerror,
+ AC_DEFINE(HAVE_HSTRERROR, 1, Define if you have the 'hstrerror' function.)
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+)
+
+AC_MSG_CHECKING(for inet_aton)
+AC_TRY_COMPILE([
+#include "confdefs.h"
+#include <sys/socket.h>
+#include <netinet/in.h>
+#include <arpa/inet.h>
+], void* p = inet_aton,
+ AC_DEFINE(HAVE_INET_ATON, 1, Define if you have the 'inet_aton' function.)
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+)
+
+AC_MSG_CHECKING(for inet_pton)
+AC_TRY_COMPILE([
+#include "confdefs.h"
+#include <sys/socket.h>
+#include <netinet/in.h>
+#include <arpa/inet.h>
+], void* p = inet_pton,
+ AC_DEFINE(HAVE_INET_PTON, 1, Define if you have the 'inet_pton' function.)
+ AC_MSG_RESULT(yes),
+ AC_MSG_RESULT(no)
+)
+
AC_MSG_CHECKING(for setgroups)
AC_TRY_COMPILE([
#include "confdefs.h"