summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>2002-12-30 16:25:41 (GMT)
committerGuido van Rossum <guido@python.org>2002-12-30 16:25:41 (GMT)
commitfaf5e4d48f9d8cb78a35e71c560dda8d1d2d7115 (patch)
treea89a21dd868d8025845cb9bd92f984b37f9bf58a /configure.in
parent1fb22bb24fd395a12a225b2418ea8d22d5b37610 (diff)
downloadcpython-faf5e4d48f9d8cb78a35e71c560dda8d1d2d7115.zip
cpython-faf5e4d48f9d8cb78a35e71c560dda8d1d2d7115.tar.gz
cpython-faf5e4d48f9d8cb78a35e71c560dda8d1d2d7115.tar.bz2
Patch 659834 by Magnus Lie Hetland:
Check for readline 2.2 features. This should make it possible to compile readline.c again with GNU readline versions 2.0 or 2.1; this ability was removed in readline.c rev. 2.49. Apparently the older versions are still in widespread deployment on older Solaris installations. With an older readline, completion behavior is subtly different (a space is always added).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b4bbdb6..4869dd1 100644
--- a/configure.in
+++ b/configure.in
@@ -2381,6 +2381,17 @@ then
[Define this if you have flockfile(), getc_unlocked(), and funlockfile()])
fi
+# check for readline 2.2
+AC_TRY_CPP([#include <readline/readline.h>],
+have_readline=yes, have_readline=no)
+if test $have_readline = yes
+then
+ AC_EGREP_HEADER([extern int rl_completion_append_character;],
+ [readline/readline.h],
+ AC_DEFINE(HAVE_RL_COMPLETION_APPEND_CHARACTER, 1,
+ [Define if you have readline 2.2]), )
+fi
+
# check for readline 4.0
AC_CHECK_LIB(readline, rl_pre_input_hook,
AC_DEFINE(HAVE_RL_PRE_INPUT_HOOK, 1,