summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2010-01-01 16:04:23 (GMT)
committerBenjamin Peterson <benjamin@python.org>2010-01-01 16:04:23 (GMT)
commitd78735d8e32411a20fc31a78e705f4c067b4344f (patch)
tree89ee63b6c0a7cc94af1ea058121b668c6d60de4b /configure.in
parentb7b0019a2e8cab7c26cb0a5121496c7c6c5ea8de (diff)
downloadcpython-d78735d8e32411a20fc31a78e705f4c067b4344f.zip
cpython-d78735d8e32411a20fc31a78e705f4c067b4344f.tar.gz
cpython-d78735d8e32411a20fc31a78e705f4c067b4344f.tar.bz2
Merged revisions 77212-77215 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r77212 | benjamin.peterson | 2010-01-01 09:16:29 -0600 (Fri, 01 Jan 2010) | 1 line use pkg-config to find the libffi headers when --with-system-ffi is used #6943 ........ r77213 | benjamin.peterson | 2010-01-01 09:18:38 -0600 (Fri, 01 Jan 2010) | 1 line add note ........ r77214 | benjamin.peterson | 2010-01-01 09:20:06 -0600 (Fri, 01 Jan 2010) | 1 line fix indentation ........ r77215 | benjamin.peterson | 2010-01-01 09:21:13 -0600 (Fri, 01 Jan 2010) | 1 line allow --with-dbmliborder to specify that no dbm modules will be built #6491 ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0abb2ba..6635208 100644
--- a/configure.in
+++ b/configure.in
@@ -1872,6 +1872,14 @@ AC_MSG_CHECKING(for --with-system-ffi)
AC_ARG_WITH(system_ffi,
AC_HELP_STRING(--with-system-ffi, build _ctypes module using an installed ffi library))
+if test "$with_system_ffi" = "yes"; then
+ AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
+ LIBFFI_INCLUDEDIR="`"$PKG_CONFIG" libffi --cflags-only-I 2>/dev/null | sed -e 's/^-I//;s/ *$//'`"
+else
+ LIBFFI_INCLUDEDIR=""
+fi
+AC_SUBST(LIBFFI_INCLUDEDIR)
+
AC_MSG_RESULT($with_system_ffi)
# Check for --with-dbmliborder