summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorFred Drake <fdrake@acm.org>2000-08-31 16:11:07 (GMT)
committerFred Drake <fdrake@acm.org>2000-08-31 16:11:07 (GMT)
commitc9cb84703b016ec6d273d979aee6a6a8763846d9 (patch)
tree795b93889517903e0b23612ab7b9d62561fabfbd /configure.in
parent6102e29df28fa0707752875e23445ef1d84d5b10 (diff)
downloadcpython-c9cb84703b016ec6d273d979aee6a6a8763846d9.zip
cpython-c9cb84703b016ec6d273d979aee6a6a8763846d9.tar.gz
cpython-c9cb84703b016ec6d273d979aee6a6a8763846d9.tar.bz2
Skip Montanaro <skip@mojam.com>:
Update the build structures to automatically detect the presence of BSD db, including the proper name of the header file to include. Has all the expected niceties associated with yet-more-configure-options. ;) This checkin includes changes for non-generated files only; subsequent checkin will catch those. This is part of SourceForge patch #101272.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 25 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 3af6c3f..69ddf54 100644
--- a/configure.in
+++ b/configure.in
@@ -369,7 +369,7 @@ dnl AC_MSG_RESULT($cpp_type)
AC_HEADER_STDC
AC_CHECK_HEADERS(dlfcn.h fcntl.h limits.h locale.h ncurses.h poll.h pthread.h \
signal.h stdarg.h stddef.h stdlib.h thread.h unistd.h utime.h \
-sys/audioio.h sys/file.h sys/lock.h \
+sys/audioio.h sys/file.h sys/lock.h db_185.h db.h \
sys/param.h sys/select.h sys/socket.h sys/time.h sys/times.h \
sys/un.h sys/utsname.h sys/wait.h pty.h libutil.h)
AC_HEADER_DIRENT
@@ -812,6 +812,30 @@ else
fi
AC_MSG_RESULT($with_cycle_gc)
+# Check for LIBDB support
+# either --with-libdb or, in its absence, the presence of db.h
+AC_SUBST(USE_BSDDB_MODULE)
+USE_BSDDB_MODULE=""
+AC_MSG_CHECKING(for --with-libdb)
+AC_ARG_WITH(libdb,
+[ --with(out)-libdb disable/enable bsddb module])
+
+# default is enabled
+if test -z "$with_libdb"
+then with_libdb="yes"
+fi
+# if we found db.h, enable, unless with_libdb is expressly set to "no"
+if test "$ac_cv_header_db_h" = "yes" -a "$with_libdb" != "no"
+then with_libdb="yes"
+fi
+if test "$with_libdb" = "no"
+then
+ USE_BSDDB_MODULE="#"
+else
+ AC_DEFINE(WITH_LIBDB)
+fi
+AC_MSG_RESULT($with_libdb)
+
# Check for --with-wctype-functions
AC_MSG_CHECKING(for --with-wctype-functions)
AC_ARG_WITH(wctype-functions,