summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2010-03-09 21:49:52 (GMT)
committerBenjamin Peterson <benjamin@python.org>2010-03-09 21:49:52 (GMT)
commit0f64b0b9a350d7ac34836d5cb858de4135d8b0e4 (patch)
treec6a99961ca0a31e70094645c5b748af650a81ade /configure.in
parent1718bd13908cb6153a6ce47b6192062ee31bdcc0 (diff)
downloadcpython-0f64b0b9a350d7ac34836d5cb858de4135d8b0e4.zip
cpython-0f64b0b9a350d7ac34836d5cb858de4135d8b0e4.tar.gz
cpython-0f64b0b9a350d7ac34836d5cb858de4135d8b0e4.tar.bz2
Merged revisions 78819 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r78819 | benjamin.peterson | 2010-03-09 15:46:54 -0600 (Tue, 09 Mar 2010) | 1 line fix ugly configure output (follow up to #6943) ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 7c76479..415a35f 100644
--- a/configure.in
+++ b/configure.in
@@ -1914,6 +1914,8 @@ LIBS="$withval $LIBS"
],
[AC_MSG_RESULT(no)])
+AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
+
# Check for use of the system expat library
AC_MSG_CHECKING(for --with-system-expat)
AC_ARG_WITH(system_expat,
@@ -1926,8 +1928,7 @@ AC_MSG_CHECKING(for --with-system-ffi)
AC_ARG_WITH(system_ffi,
AC_HELP_STRING(--with-system-ffi, build _ctypes module using an installed ffi library))
-if test "$with_system_ffi" = "yes"; then
- AC_PATH_TOOL([PKG_CONFIG], [pkg-config])
+if test "$with_system_ffi" = "yes" && test -n "$PKG_CONFIG"; then
LIBFFI_INCLUDEDIR="`"$PKG_CONFIG" libffi --cflags-only-I 2>/dev/null | sed -e 's/^-I//;s/ *$//'`"
else
LIBFFI_INCLUDEDIR=""