summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2008-07-17 16:10:34 (GMT)
committerBenjamin Peterson <benjamin@python.org>2008-07-17 16:10:34 (GMT)
commit67c38e26898571a3255ab773ebca9c94f21d0950 (patch)
treee636a1915f373ddb625ba939ee8f71d28c80fc8f /configure.in
parent9da5cb930e03a21033d9e5d0ac1e447cb1605e6b (diff)
downloadcpython-67c38e26898571a3255ab773ebca9c94f21d0950.zip
cpython-67c38e26898571a3255ab773ebca9c94f21d0950.tar.gz
cpython-67c38e26898571a3255ab773ebca9c94f21d0950.tar.bz2
Merged revisions 65061 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r65061 | benjamin.peterson | 2008-07-17 10:59:24 -0500 (Thu, 17 Jul 2008) | 1 line #3381 fix framework builds on 10.4 ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in48
1 files changed, 28 insertions, 20 deletions
diff --git a/configure.in b/configure.in
index 4cf88e7..322d52b 100644
--- a/configure.in
+++ b/configure.in
@@ -858,6 +858,8 @@ yes)
Darwin*)
# -Wno-long-double, -no-cpp-precomp, and -mno-fused-madd
# used to be here, but non-Apple gcc doesn't accept them.
+
+
if test "${enable_universalsdk}"; then
UNIVERSAL_ARCH_FLAGS=""
if test "$UNIVERSAL_ARCHS" = "32-bit" ; then
@@ -878,9 +880,34 @@ yes)
BASECFLAGS="${UNIVERSAL_ARCH_FLAGS} -isysroot ${UNIVERSALSDK} ${BASECFLAGS}"
- CFLAGS="${UNIVERSAL_ARCH_FLAGS} -isysroot ${UNIVERSALSDK} ${CFLAGS}"
+ tgt=`sw_vers -productVersion | sed 's/\(10\.[0-9]*\).*/\1/'`
+ if test "${UNIVERSALSDK}" != "/" -a "${tgt}" '>' '10.4' ; then
+ CFLAGS="${UNIVERSAL_ARCH_FLAGS} -isysroot ${UNIVERSALSDK} ${CFLAGS}"
+ fi
fi
+ # Calculate the right deployment target for this build.
+ #
+ cur_target=`sw_vers -productVersion | sed 's/\(10\.[[0-9]]*\).*/\1/'`
+ if test ${cur_target} '>' 10.2; then
+ cur_target=10.3
+ fi
+ if test "${UNIVERSAL_ARCHS}" = "all"; then
+ # Ensure that the default platform for a 4-way
+ # universal build is OSX 10.5, that's the first
+ # OS release where 4-way builds make sense.
+ cur_target='10.5'
+ fi
+ CONFIGURE_MACOSX_DEPLOYMENT_TARGET=${MACOSX_DEPLOYMENT_TARGET-${cur_target}}
+
+ # Make sure that MACOSX_DEPLOYMENT_TARGET is set in the
+ # environment with a value that is the same as what we'll use
+ # in the Makefile to ensure that we'll get the same compiler
+ # environment during configure and build time.
+ MACOSX_DEPLOYMENT_TARGET="$CONFIGURE_MACOSX_DEPLOYMENT_TARGET"
+ export MACOSX_DEPLOYMENT_TARGET
+ EXPORT_MACOSX_DEPLOYMENT_TARGET=''
+
;;
OSF*)
BASECFLAGS="$BASECFLAGS -mieee"
@@ -1550,26 +1577,7 @@ then
Darwin/*)
# Use -undefined dynamic_lookup whenever possible (10.3 and later).
# This allows an extension to be used in any Python
- cur_target=`sw_vers -productVersion | sed 's/\(10\.[[0-9]]*\).*/\1/'`
- if test ${cur_target} '>' 10.2; then
- cur_target=10.3
- fi
- if test "${UNIVERSAL_ARCHS}" = "all"; then
- # Ensure that the default platform for a 4-way
- # universal build is OSX 10.5, that's the first
- # OS release where 4-way builds make sense.
- cur_target='10.5'
- fi
- CONFIGURE_MACOSX_DEPLOYMENT_TARGET=${MACOSX_DEPLOYMENT_TARGET-${cur_target}}
-
- # Make sure that MACOSX_DEPLOYMENT_TARGET is set in the
- # environment with a value that is the same as what we'll use
- # in the Makefile to ensure that we'll get the same compiler
- # environment during configure and build time.
- MACOSX_DEPLOYMENT_TARGET="$CONFIGURE_MACOSX_DEPLOYMENT_TARGET"
- export MACOSX_DEPLOYMENT_TARGET
- EXPORT_MACOSX_DEPLOYMENT_TARGET=''
if test ${MACOSX_DEPLOYMENT_TARGET} '>' 10.2
then
if test "${enable_universalsdk}"; then