summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2010-04-30 11:41:56 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2010-04-30 11:41:56 (GMT)
commit86b33c872defc95a4e7e132a16dd88f02a20265b (patch)
tree3c98ac9c86d3cf56b6c601d2ccc047227fcd60a2 /configure.in
parent0ea2a468e31b3ec20ae4281d9c28d1f5db7912d9 (diff)
downloadcpython-86b33c872defc95a4e7e132a16dd88f02a20265b.zip
cpython-86b33c872defc95a4e7e132a16dd88f02a20265b.tar.gz
cpython-86b33c872defc95a4e7e132a16dd88f02a20265b.tar.bz2
Merged revisions 80647 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r80647 | ronald.oussoren | 2010-04-30 13:20:14 +0200 (Fri, 30 Apr 2010) | 11 lines Fix for issue #3646: with this patch it is possible to do a framework install of Python in your home directory (on OSX): $ configure --enable-framework=${HOME}/Library/Frameworks $ make && make install Without this patch the framework would get installed just fine, but 'make install' would try to install the application bundles and command-line tools outside the user's home, which doesn't work for non-admin users (and is bad form anyway). ........
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in40
1 files changed, 39 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d4f74bc..c127a63 100644
--- a/configure.in
+++ b/configure.in
@@ -179,18 +179,55 @@ AC_ARG_ENABLE(framework,
enable_framework=
;;
*)
- PYTHONFRAMEWORKPREFIX=$enableval
+ PYTHONFRAMEWORKPREFIX="${enableval}"
PYTHONFRAMEWORKINSTALLDIR=$PYTHONFRAMEWORKPREFIX/$PYTHONFRAMEWORKDIR
FRAMEWORKINSTALLFIRST="frameworkinstallstructure"
FRAMEWORKALTINSTALLFIRST="frameworkinstallstructure "
FRAMEWORKINSTALLLAST="frameworkinstallmaclib frameworkinstallapps frameworkinstallunixtools"
FRAMEWORKALTINSTALLLAST="frameworkinstallmaclib frameworkinstallapps frameworkaltinstallunixtools"
+ FRAMEWORKINSTALLAPPSPREFIX="/Applications"
if test "x${prefix}" = "xNONE" ; then
FRAMEWORKUNIXTOOLSPREFIX="${ac_default_prefix}"
+
else
FRAMEWORKUNIXTOOLSPREFIX="${prefix}"
fi
+
+ case "${enableval}" in
+ /System*)
+ FRAMEWORKINSTALLAPPSPREFIX="/Applications"
+ if test "${prefix}" = "NONE" ; then
+ # See below
+ FRAMEWORKUNIXTOOLSPREFIX="/usr"
+ fi
+ ;;
+
+ /Library*)
+ FRAMEWORKINSTALLAPPSPREFIX="/Applications"
+ ;;
+
+ */Library/Frameworks)
+ MDIR="`dirname "${enableval}"`"
+ MDIR="`dirname "${MDIR}"`"
+ FRAMEWORKINSTALLAPPSPREFIX="${MDIR}/Applications"
+
+ if test "${prefix}" = "NONE"; then
+ # User hasn't specified the
+ # --prefix option, but wants to install
+ # the framework in a non-default location,
+ # ensure that the compatibility links get
+ # installed relative to that prefix as well
+ # instead of in /usr/local.
+ FRAMEWORKUNIXTOOLSPREFIX="${MDIR}"
+ fi
+ ;;
+
+ *)
+ FRAMEWORKINSTALLAPPSPREFIX="/Applications"
+ ;;
+ esac
+
prefix=$PYTHONFRAMEWORKINSTALLDIR/Versions/$VERSION
# Add files for Mac specific code to the list of output
@@ -227,6 +264,7 @@ AC_SUBST(FRAMEWORKINSTALLLAST)
AC_SUBST(FRAMEWORKALTINSTALLFIRST)
AC_SUBST(FRAMEWORKALTINSTALLLAST)
AC_SUBST(FRAMEWORKUNIXTOOLSPREFIX)
+AC_SUBST(FRAMEWORKINSTALLAPPSPREFIX)
##AC_ARG_WITH(dyld,
## AS_HELP_STRING([--with-dyld],