summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAntoine Pitrou <solipsis@pitrou.net>2010-09-10 19:44:44 (GMT)
committerAntoine Pitrou <solipsis@pitrou.net>2010-09-10 19:44:44 (GMT)
commit8e6b407d6fdca02f84409790a4c1f92478ac8dc1 (patch)
tree8eacdf08153b0656255fc9eb691a62698f485057 /configure.in
parentdfa9b294fac33934547b5f7b7542466c469e6599 (diff)
downloadcpython-8e6b407d6fdca02f84409790a4c1f92478ac8dc1.zip
cpython-8e6b407d6fdca02f84409790a4c1f92478ac8dc1.tar.gz
cpython-8e6b407d6fdca02f84409790a4c1f92478ac8dc1.tar.bz2
Issue #941346: Improve the build process under AIX and allow Python to
be built as a shared library. Patch by Sébastien Sablé.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 5caa5d7..b467284 100644
--- a/configure.in
+++ b/configure.in
@@ -766,6 +766,10 @@ if test $enable_shared = "yes"; then
BLDLIBRARY='-L. -lpython$(VERSION)'
RUNSHARED='DYLD_LIBRARY_PATH=`pwd`:${DYLD_LIBRARY_PATH}'
;;
+ AIX*)
+ LDLIBRARY='libpython$(VERSION).so'
+ RUNSHARED=LIBPATH=`pwd`:${LIBPATH}
+ ;;
esac
else # shared is disabled
@@ -1665,7 +1669,7 @@ if test -z "$LDSHARED"
then
case $ac_sys_system/$ac_sys_release in
AIX*)
- BLDSHARED="\$(srcdir)/Modules/ld_so_aix \$(CC) -bI:Modules/python.exp"
+ BLDSHARED="\$(srcdir)/Modules/ld_so_aix \$(CC) -bI:Modules/python.exp -L\$(srcdir)"
LDSHARED="\$(BINLIBDEST)/config/ld_so_aix \$(CC) -bI:\$(BINLIBDEST)/config/python.exp"
;;
IRIX/5*) LDSHARED="ld -shared";;
@@ -4247,6 +4251,7 @@ AC_MSG_RESULT(done)
# generate output files
AC_CONFIG_FILES(Makefile.pre Modules/Setup.config Misc/python.pc)
+AC_CONFIG_FILES([Modules/ld_so_aix], [chmod +x Modules/ld_so_aix])
AC_OUTPUT
echo "creating Modules/Setup"