summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorHye-Shik Chang <hyeshik@gmail.com>2004-10-26 09:53:46 (GMT)
committerHye-Shik Chang <hyeshik@gmail.com>2004-10-26 09:53:46 (GMT)
commit337614993e6f329143e5a68349b62f0a43114ac9 (patch)
tree5a2e1a95f3615bf9b80813a455f479962ae524c2 /configure.in
parent182ac8514726402451a90fd59c9bf427f8071365 (diff)
downloadcpython-337614993e6f329143e5a68349b62f0a43114ac9.zip
cpython-337614993e6f329143e5a68349b62f0a43114ac9.tar.gz
cpython-337614993e6f329143e5a68349b62f0a43114ac9.tar.bz2
Patch #1044395: Allow configure option --enable-shared in FreeBSD.
(Submitted by James William Pye, Patch revised by Jiwon Seo)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 981d2ba..cc98881 100644
--- a/configure.in
+++ b/configure.in
@@ -557,10 +557,15 @@ if test $enable_shared = "yes"; then
RUNSHARED=LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}
INSTSONAME="$LDLIBRARY".$SOVERSION
;;
- Linux*|GNU*|NetBSD*)
+ Linux*|GNU*|NetBSD*|FreeBSD*)
LDLIBRARY='libpython$(VERSION).so'
BLDLIBRARY='-L. -lpython$(VERSION)'
RUNSHARED=LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}
+ case $ac_sys_system in
+ FreeBSD*)
+ SOVERSION=`echo $SOVERSION|cut -d "." -f 1`
+ ;;
+ esac
INSTSONAME="$LDLIBRARY".$SOVERSION
;;
hp*|HP*)
@@ -1345,7 +1350,7 @@ then
OpenBSD*|FreeBSD*)
if [[ "`$CC -dM -E - </dev/null | grep __ELF__`" != "" ]]
then
- LDSHARED="cc -shared ${LDFLAGS}"
+ LDSHARED="$CC -shared ${LDFLAGS}"
else
LDSHARED="ld -Bshareable ${LDFLAGS}"
fi;;