summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorBarry Warsaw <barry@python.org>2000-06-30 16:21:01 (GMT)
committerBarry Warsaw <barry@python.org>2000-06-30 16:21:01 (GMT)
commitef82cd72341158ec791406215da198e8a5508357 (patch)
treec31eac122688bb57ab3cdc325e5612062cafdff4 /configure.in
parent615ae55eca17c1632e23f52c5842bb338d633ddf (diff)
downloadcpython-ef82cd72341158ec791406215da198e8a5508357.zip
cpython-ef82cd72341158ec791406215da198e8a5508357.tar.gz
cpython-ef82cd72341158ec791406215da198e8a5508357.tar.bz2
Enable the garbage collection module by default. --without-cycle-gc
disables it. The gc test is moved to just after the thread test, as is the wctype-functions test. Modules/Setup.config is generated instead of Modules/Setup.thread. Applied SF patch #100684 (loewis) to fix help alignment bug.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in51
1 files changed, 29 insertions, 22 deletions
diff --git a/configure.in b/configure.in
index 152d1f0..876f71d 100644
--- a/configure.in
+++ b/configure.in
@@ -722,6 +722,34 @@ else
LIBOBJS="$LIBOBJS thread.o"])
fi
+# Check for GC support
+AC_SUBST(USE_GC_MODULE)
+USE_GC_MODULE=""
+AC_MSG_CHECKING(for --with-cycle-gc)
+AC_ARG_WITH(cycle-gc,
+[ --with(out)-cycle-gc disable/enable garbage collection])
+
+if test -z "$with_cycle_gc"
+then with_cycle_gc="yes"
+fi
+if test "$with_cycle_gc" = "no"
+then
+ USE_GC_MODULE="#"
+else
+ AC_DEFINE(WITH_CYCLE_GC)
+fi
+AC_MSG_RESULT($with_cycle_gc)
+
+# Check for --with-wctype-functions
+AC_MSG_CHECKING(for --with-wctype-functions)
+AC_ARG_WITH(wctype-functions,
+[ --with-wctype-functions use wctype.h functions], [
+if test "$withval" != no
+then AC_DEFINE(WANT_WCTYPE_FUNCTIONS) AC_MSG_RESULT(yes)
+else AC_MSG_RESULT(no)
+fi],
+[AC_MSG_RESULT(no)])
+
# -I${DLINCLDIR} is added to the compile rule for importdl.o
AC_SUBST(DLINCLDIR)
DLINCLDIR=/
@@ -1106,27 +1134,6 @@ AC_MSG_RESULT($usable_wchar_t)
# check for endianness
AC_C_BIGENDIAN
-# Check for --with-wctype-functions
-AC_MSG_CHECKING(for --with-wctype-functions)
-AC_ARG_WITH(wctype-functions,
-[ --with-wctype-functions use wctype.h functions], [
-if test "$withval" != no
-then AC_DEFINE(WANT_WCTYPE_FUNCTIONS) AC_MSG_RESULT(yes)
-else AC_MSG_RESULT(no)
-fi],
-[AC_MSG_RESULT(no)])
-
-# Check for GC support
-AC_SUBST(USE_GC_MODULE)
-USE_GC_MODULE="#"
-AC_MSG_CHECKING(for --with-cycle-gc)
-AC_ARG_WITH(cycle-gc, [--with-cycle-gc enable garbage collection], [
-AC_MSG_RESULT($withval)
-AC_DEFINE(WITH_CYCLE_GC)
-USE_GC_MODULE=
-],
-AC_MSG_RESULT(no))
-
# THIS MUST BE LAST, IT CAN BREAK OTHER TESTS!
# Add sys/socket.h to confdefs.h
cat >> confdefs.h <<\EOF
@@ -1142,4 +1149,4 @@ AC_OUTPUT(Makefile \
Parser/Makefile \
Python/Makefile \
Modules/Makefile.pre \
- Modules/Setup.thread)
+ Modules/Setup.config)