summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJesse Noller <jnoller@gmail.com>2009-03-31 18:48:42 (GMT)
committerJesse Noller <jnoller@gmail.com>2009-03-31 18:48:42 (GMT)
commit32d68c27880d4ad40c3f06e5397a539a38a85a6f (patch)
tree5c0163cf6777d3d923f1eab229371cde1b4af25f /setup.py
parentce9fbd3662f87f5e3192b0c4c1c39a6c4ef452ee (diff)
downloadcpython-32d68c27880d4ad40c3f06e5397a539a38a85a6f.zip
cpython-32d68c27880d4ad40c3f06e5397a539a38a85a6f.tar.gz
cpython-32d68c27880d4ad40c3f06e5397a539a38a85a6f.tar.bz2
Merged revisions 70849,70852 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r70849 | jesse.noller | 2009-03-31 13:12:35 -0500 (Tue, 31 Mar 2009) | 1 line Apply patch for netbsd multiprocessing support ........ r70852 | jesse.noller | 2009-03-31 13:27:14 -0500 (Tue, 31 Mar 2009) | 1 line missed the news/acks for netbsd patch ........
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 9 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 522eb82..3c25172 100644
--- a/setup.py
+++ b/setup.py
@@ -1023,6 +1023,15 @@ class PyBuildExt(build_ext):
)
libraries = []
+ elif platform.startswith('netbsd'):
+ macros = dict( # at least NetBSD 5
+ HAVE_SEM_OPEN=1,
+ HAVE_SEM_TIMEDWAIT=0,
+ HAVE_FD_TRANSFER=1,
+ HAVE_BROKEN_SEM_GETVALUE=1
+ )
+ libraries = []
+
else: # Linux and other unices
macros = dict(
HAVE_SEM_OPEN=1,