summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Heller <theller@ctypes.org>2008-05-23 17:26:46 (GMT)
committerThomas Heller <theller@ctypes.org>2008-05-23 17:26:46 (GMT)
commit3eaaeb437f7283ef60ead8464d8da6bfac4f93aa (patch)
treef5192fe4214bf1025a5682a30196c85004a49806 /setup.py
parentab081cfbb1b45c707ceb48048c8a989f47f27a78 (diff)
downloadcpython-3eaaeb437f7283ef60ead8464d8da6bfac4f93aa.zip
cpython-3eaaeb437f7283ef60ead8464d8da6bfac4f93aa.tar.gz
cpython-3eaaeb437f7283ef60ead8464d8da6bfac4f93aa.tar.bz2
Merged revisions 63395-63396,63511,63522-63523 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r63395 | thomas.heller | 2008-05-16 22:06:31 +0200 (Fr, 16 Mai 2008) | 4 lines Issue 1793: Add ctypes.util.find_msvcrt() function (on Windows). ........ r63396 | thomas.heller | 2008-05-16 22:19:07 +0200 (Fr, 16 Mai 2008) | 4 lines Very simple test for ctypes.util.find_library on Windows. ........ r63511 | thomas.heller | 2008-05-20 21:53:47 +0200 (Di, 20 Mai 2008) | 6 lines On HPUX, -fPIC must be used for linking. _ctypes now builds on HP-UX IA64 and PA machines. The ctypes unittests work fine on the IA64, but dump core in test_qsort on the PA. ........ r63522 | thomas.heller | 2008-05-21 20:47:02 +0200 (Mi, 21 Mai 2008) | 2 lines The -x <test1[,test2...]> flag allows to exclude tests. ........ r63523 | thomas.heller | 2008-05-21 21:47:44 +0200 (Mi, 21 Mai 2008) | 2 lines Oops, get_tests may be called with 3 arguments. ........
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index c339ba8..34e6c39 100644
--- a/setup.py
+++ b/setup.py
@@ -1408,6 +1408,9 @@ class PyBuildExt(build_ext):
# finding some -z option for the Sun compiler.
extra_link_args.append('-mimpure-text')
+ elif sys.platform.startswith('hpux'):
+ extra_link_args.append('-fPIC')
+
ext = Extension('_ctypes',
include_dirs=include_dirs,
extra_compile_args=extra_compile_args,