summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBarry Warsaw <barry@python.org>2002-12-30 20:51:12 (GMT)
committerBarry Warsaw <barry@python.org>2002-12-30 20:51:12 (GMT)
commit40819d551545db13cdfd46c773ffe3bc4f1f9ca0 (patch)
tree789f6664f6bc0140e2190c93643965d987d3ef56 /setup.py
parent74859f3aa63698364a9062d6f49fb223eead1dd7 (diff)
downloadcpython-40819d551545db13cdfd46c773ffe3bc4f1f9ca0.zip
cpython-40819d551545db13cdfd46c773ffe3bc4f1f9ca0.tar.gz
cpython-40819d551545db13cdfd46c773ffe3bc4f1f9ca0.tar.bz2
Search for and use BerkeleyDB 4.1 if it's available. Python's
extension module now supports it.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py19
1 files changed, 9 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 5e41112..cad529b 100644
--- a/setup.py
+++ b/setup.py
@@ -449,27 +449,26 @@ class PyBuildExt(build_ext):
# implementation independent wrapper for these; dumbdbm.py provides
# similar functionality (but slower of course) implemented in Python.
- # Sleepycat Berkeley DB interface.
+ # Sleepycat Berkeley DB interface. http://www.sleepycat.com
#
- # This requires the Sleepycat DB code, see
- # http://www.sleepycat.com/ The earliest supported version of
- # that library is 3.0, the latest supported version is 4.0
- # (4.1 is specifically not supported, as that changes the
- # semantics of transactional databases). A list of available
- # releases can be found at
+ # This requires the Sleepycat DB code. The earliest supported version
+ # of that library is 3.0, the latest supported version is 4.1. A list
+ # of available releases can be found at
#
# http://www.sleepycat.com/update/index.html
# when sorted in reverse order, keys for this dict must appear in the
# order you wish to search - e.g., search for db4 before db3
db_try_this = {
- 'db4': {'libs': ('db-4.0',),
- 'libdirs': ('/usr/local/BerkeleyDB.4.0/lib',
+ 'db4': {'libs': ('db-4.1', 'db-4.0',),
+ 'libdirs': ('/usr/local/BerkeleyDB.4.1/lib',
+ '/usr/local/BerkeleyDB.4.0/lib',
'/usr/local/lib',
'/opt/sfw',
'/sw/lib',
),
- 'incdirs': ('/usr/local/BerkeleyDB.4.0/include',
+ 'incdirs': ('/usr/local/BerkeleyDB.4.1/include',
+ '/usr/local/BerkeleyDB.4.0/include',
'/usr/local/include/db4',
'/opt/sfw/include/db4',
'/sw/include/db4',