summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2002-12-12 20:23:38 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2002-12-12 20:23:38 (GMT)
commit427a290c9afca605ab8ed799f0072d890318b837 (patch)
treec7878af270533d7ca7f91532e2d1edf1b88c1e08 /setup.py
parent00b6127097f10d7fb03ab5abcd213141b878a8fd (diff)
downloadcpython-427a290c9afca605ab8ed799f0072d890318b837.zip
cpython-427a290c9afca605ab8ed799f0072d890318b837.tar.gz
cpython-427a290c9afca605ab8ed799f0072d890318b837.tar.bz2
Patch #629126: Detect BLT by also looking for libBLT.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 2827af7..bc49d74 100644
--- a/setup.py
+++ b/setup.py
@@ -950,6 +950,10 @@ class PyBuildExt(build_ext):
'BLT8.0'):
defs.append( ('WITH_BLT', 1) )
libs.append('BLT8.0')
+ elif self.compiler.find_library_file(lib_dirs + added_lib_dirs,
+ 'BLT'):
+ defs.append( ('WITH_BLT', 1) )
+ libs.append('BLT')
# Add the Tcl/Tk libraries
libs.append('tk'+version)