summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMatthias Klose <doko@ubuntu.com>2010-04-21 22:21:03 (GMT)
committerMatthias Klose <doko@ubuntu.com>2010-04-21 22:21:03 (GMT)
commit4c4b078101fcb8502efac17d3f8d335700195337 (patch)
treea87b3334bc9b1b45acd845b88fa36c21b746efb7 /setup.py
parent5a204fed7e14aa864de1bd24daf95656eee07d96 (diff)
downloadcpython-4c4b078101fcb8502efac17d3f8d335700195337.zip
cpython-4c4b078101fcb8502efac17d3f8d335700195337.tar.gz
cpython-4c4b078101fcb8502efac17d3f8d335700195337.tar.bz2
Merged revisions 80322 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r80322 | matthias.klose | 2010-04-22 00:18:52 +0200 (Do, 22 Apr 2010) | 2 lines - Build the ossaudio extension on GNU/kFreeBSD. ........
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index ada6ca4..42ef2c0 100644
--- a/setup.py
+++ b/setup.py
@@ -1227,8 +1227,9 @@ class PyBuildExt(build_ext):
# End multiprocessing
# Platform-specific libraries
- if platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6',
- 'freebsd7', 'freebsd8'):
+ if (platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6',
+ 'freebsd7', 'freebsd8')
+ or platform.startswith("gnukfreebsd")):
exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) )
else:
missing.append('ossaudiodev')