summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorFred Drake <fdrake@acm.org>2002-08-05 18:06:17 (GMT)
committerFred Drake <fdrake@acm.org>2002-08-05 18:06:17 (GMT)
commit5f8a23f32fb32476d97c0be4c7da2dea5efe3393 (patch)
treedc5106a121569fdb310fca62eb22e67c4921d1b8 /setup.py
parent2805428d92f165064c0f7f4c12aa3c0c5e4ed1eb (diff)
downloadcpython-5f8a23f32fb32476d97c0be4c7da2dea5efe3393.zip
cpython-5f8a23f32fb32476d97c0be4c7da2dea5efe3393.tar.gz
cpython-5f8a23f32fb32476d97c0be4c7da2dea5efe3393.tar.bz2
Since the errno module is needed by os._execvpe(), and that is used by the
setup.py (indirectly) script to build the standard dynamically loaded modules, the errno module is being made static so it will always be available. Closes SF bug #591205 (needed on trunk only).
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 0 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 21f0d88..5ac3c29 100644
--- a/setup.py
+++ b/setup.py
@@ -315,8 +315,6 @@ class PyBuildExt(build_ext):
exts.append( Extension('pwd', ['pwdmodule.c']) )
# grp(3)
exts.append( Extension('grp', ['grpmodule.c']) )
- # posix (UNIX) errno values
- exts.append( Extension('errno', ['errnomodule.c']) )
# select(2); not on ancient System V
exts.append( Extension('select', ['selectmodule.c']) )