summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2002-01-21 23:10:36 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2002-01-21 23:10:36 (GMT)
commit796720b3148c05efb2eff1852241d16c0d4ae8eb (patch)
treee39c60fcd13196e1833adb9cca9216876acd85fb /setup.py
parenteafff4c248a22360632e49a42580dc0635f1423e (diff)
downloadcpython-796720b3148c05efb2eff1852241d16c0d4ae8eb.zip
cpython-796720b3148c05efb2eff1852241d16c0d4ae8eb.tar.gz
cpython-796720b3148c05efb2eff1852241d16c0d4ae8eb.tar.bz2
Mac _Scrap module is now carbon-compliant, so build it on OSX.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8f5bf07..8e3669a 100644
--- a/setup.py
+++ b/setup.py
@@ -653,7 +653,8 @@ class PyBuildExt(build_ext):
exts.append( Extension('_Qt', ['qt/_Qtmodule.c'],
extra_link_args=['-framework', 'QuickTime',
'-framework', 'Carbon']) )
-## exts.append( Extension('_Scrap', ['scrap/_Scrapmodule.c']) )
+ exts.append( Extension('_Scrap', ['scrap/_Scrapmodule.c'],
+ extra_link_args=['-framework', 'Carbon']) )
exts.append( Extension('_TE', ['te/_TEmodule.c'],
extra_link_args=['-framework', 'Carbon']) )
# As there is no standardized place (yet) to put user-installed