diff options
author | Ronald Oussoren <ronaldoussoren@mac.com> | 2010-04-18 20:46:11 (GMT) |
---|---|---|
committer | Ronald Oussoren <ronaldoussoren@mac.com> | 2010-04-18 20:46:11 (GMT) |
commit | 8415120af34d7239dca90f6cd47d0714c226d123 (patch) | |
tree | 350627ffb1ae96418a7dcd31eeeee0a6ca8e8f8f /setup.py | |
parent | f88db8de767460a6a2bd4307278ba6e9253b7770 (diff) | |
download | cpython-8415120af34d7239dca90f6cd47d0714c226d123.zip cpython-8415120af34d7239dca90f6cd47d0714c226d123.tar.gz cpython-8415120af34d7239dca90f6cd47d0714c226d123.tar.bz2 |
For for issue #7154: Port the code that uses
the SystemConfiguration framework to detect the
proxy settings on OSX from the trunk to python 3.2
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 6 insertions, 0 deletions
@@ -1238,6 +1238,12 @@ class PyBuildExt(build_ext): Extension('_gestalt', ['_gestalt.c'], extra_link_args=['-framework', 'Carbon']) ) + exts.append( + Extension('_scproxy', ['_scproxy.c'], + extra_link_args=[ + '-framework', 'SystemConfiguration', + '-framework', 'CoreFoundation', + ])) self.extensions.extend(exts) |