summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorRonald Oussoren <ronaldoussoren@mac.com>2010-03-08 07:09:59 (GMT)
committerRonald Oussoren <ronaldoussoren@mac.com>2010-03-08 07:09:59 (GMT)
commit961683ac0f37de933ed15ccc60a9eee1a2fbcefc (patch)
treeb9ba943583ddbdc8beca9529268ede4ae7a9f905 /setup.py
parentb8f11a665e4ae30ae46494342e11718e69f79a88 (diff)
downloadcpython-961683ac0f37de933ed15ccc60a9eee1a2fbcefc.zip
cpython-961683ac0f37de933ed15ccc60a9eee1a2fbcefc.tar.gz
cpython-961683ac0f37de933ed15ccc60a9eee1a2fbcefc.tar.bz2
Merged revisions 78784 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk ........ r78784 | ronald.oussoren | 2010-03-08 08:06:47 +0100 (Mon, 08 Mar 2010) | 3 lines Fix for issue 8066: readline should not be linked against libedit when the deployment target is 10.4, libedit on 10.4 is too broken. ........
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 8ca5858..5c1b382 100644
--- a/setup.py
+++ b/setup.py
@@ -492,6 +492,9 @@ class PyBuildExt(build_ext):
do_readline = self.compiler_obj.find_library_file(lib_dirs, 'readline')
if platform == 'darwin':
os_release = int(os.uname()[2].split('.')[0])
+ dep_target = sysconfig.get_config_var('MACOSX_DEPLOYMENT_TARGET')
+ if dep_target and dep_target.split('.') < ['10', '5']:
+ os_release = 8
if os_release < 9:
# MacOSX 10.4 has a broken readline. Don't try to build
# the readline module unless the user has installed a fixed