diff options
author | Benjamin Peterson <benjamin@python.org> | 2009-05-23 16:34:23 (GMT) |
---|---|---|
committer | Benjamin Peterson <benjamin@python.org> | 2009-05-23 16:34:23 (GMT) |
commit | 9c80cacb8cede5830447e7bff4e03a35293fa148 (patch) | |
tree | f43032f40f40b53afafe2b85462db879fa2a5c8c /setup.py | |
parent | 932073a1695454708fee8acba2fec2a6802d5421 (diff) | |
download | cpython-9c80cacb8cede5830447e7bff4e03a35293fa148.zip cpython-9c80cacb8cede5830447e7bff4e03a35293fa148.tar.gz cpython-9c80cacb8cede5830447e7bff4e03a35293fa148.tar.bz2 |
build _functools and _locale into the core library
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 18 |
1 files changed, 0 insertions, 18 deletions
@@ -424,8 +424,6 @@ class PyBuildExt(build_ext): exts.append( Extension("_heapq", ["_heapqmodule.c"]) ) # operator.add() and similar goodies exts.append( Extension('operator', ['operator.c']) ) - # _functools - exts.append( Extension("_functools", ["_functoolsmodule.c"]) ) # C-optimized pickle replacement exts.append( Extension("_pickle", ["_pickle.c"]) ) # atexit @@ -439,22 +437,6 @@ class PyBuildExt(build_ext): exts.append( Extension('_lsprof', ['_lsprof.c', 'rotatingtree.c']) ) # static Unicode character database exts.append( Extension('unicodedata', ['unicodedata.c']) ) - # access to ISO C locale support - data = open('pyconfig.h').read() - m = re.search(r"#s*define\s+WITH_LIBINTL\s+1\s*", data) - if m is not None: - locale_libs = ['intl'] - else: - locale_libs = [] - if platform == 'darwin': - locale_extra_link_args = ['-framework', 'CoreFoundation'] - else: - locale_extra_link_args = [] - - - exts.append( Extension('_locale', ['_localemodule.c'], - libraries=locale_libs, - extra_link_args=locale_extra_link_args) ) # Modules with some UNIX dependencies -- on by default: # (If you have a really backward UNIX, select and socket may not be |