summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorGregory P. Smith <greg@mad-scientist.com>2007-09-09 18:01:42 (GMT)
committerGregory P. Smith <greg@mad-scientist.com>2007-09-09 18:01:42 (GMT)
commitb2c3a537cd89dd8f5f47ea991c6724295b2c06e5 (patch)
tree9b418314b82a892ae9144b1033fcd8e3c336d960 /setup.py
parent2f21eb3a153ee09e333300a837be86a37cd22d28 (diff)
downloadcpython-b2c3a537cd89dd8f5f47ea991c6724295b2c06e5.zip
cpython-b2c3a537cd89dd8f5f47ea991c6724295b2c06e5.tar.gz
cpython-b2c3a537cd89dd8f5f47ea991c6724295b2c06e5.tar.bz2
openssl 0.9.6 is too old to use, use our own modules
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index b2e1cac..b79ea05 100644
--- a/setup.py
+++ b/setup.py
@@ -613,12 +613,12 @@ class PyBuildExt(build_ext):
else:
missing.append('_hashlib')
- if (openssl_ver < 0x00908000):
+ if openssl_ver < 0x00908000:
# OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
exts.append( Extension('_sha256', ['sha256module.c']) )
exts.append( Extension('_sha512', ['sha512module.c']) )
- if not openssl_ver:
+ if openssl_ver < 0x00907000:
# no openssl at all, use our own md5 and sha1
exts.append( Extension('_md5', ['md5module.c']) )
exts.append( Extension('_sha1', ['sha1module.c']) )