summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorNeil Schemenauer <nascheme@enme.ucalgary.ca>2001-10-21 22:14:44 (GMT)
committerNeil Schemenauer <nascheme@enme.ucalgary.ca>2001-10-21 22:14:44 (GMT)
commitc3ffef66665eade1e2fc10dcc271828a995ef74e (patch)
tree9bd089319eaca3d4774109487bb64ab095cac49b /setup.py
parentdac58492aa3bf476fa0b4b586edababfe3aaca53 (diff)
downloadcpython-c3ffef66665eade1e2fc10dcc271828a995ef74e.zip
cpython-c3ffef66665eade1e2fc10dcc271828a995ef74e.tar.gz
cpython-c3ffef66665eade1e2fc10dcc271828a995ef74e.tar.bz2
- Build dbm module using libdb1 if it's available. This fixes SF bug "[
#230075 ] dbmmodule build fails on Debian GNU/Linux unstable (Sid)". - Build bsddb module with libdb3 if it's available. It also fixes a bug that causes the build of bsddb to fail on Debian if bsddb3-dev is installed.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index b3b52f5..c525e03 100644
--- a/setup.py
+++ b/setup.py
@@ -362,6 +362,9 @@ class PyBuildExt(build_ext):
if (self.compiler.find_library_file(lib_dirs, 'ndbm')):
exts.append( Extension('dbm', ['dbmmodule.c'],
libraries = ['ndbm'] ) )
+ elif self.compiler.find_library_file(lib_dirs, 'db1'):
+ exts.append( Extension('dbm', ['dbmmodule.c'],
+ libraries = ['db1'] ) )
else:
exts.append( Extension('dbm', ['dbmmodule.c']) )
@@ -384,6 +387,8 @@ class PyBuildExt(build_ext):
dblib = []
if self.compiler.find_library_file(lib_dirs, 'db-3.1'):
dblib = ['db-3.1']
+ elif self.compiler.find_library_file(lib_dirs, 'db3'):
+ dblib = ['db3']
elif self.compiler.find_library_file(lib_dirs, 'db2'):
dblib = ['db2']
elif self.compiler.find_library_file(lib_dirs, 'db1'):