diff options
author | Skip Montanaro <skip@pobox.com> | 2002-08-15 01:34:38 (GMT) |
---|---|---|
committer | Skip Montanaro <skip@pobox.com> | 2002-08-15 01:34:38 (GMT) |
commit | ccfdde86eb56b5e24d44e18aa1c276be475aeee2 (patch) | |
tree | 917a582fac86ee0df93517bac83eeffc57583f23 /setup.py | |
parent | 8c9133722153eb01c92d3dcaf5ded2cb8fb7a8d9 (diff) | |
download | cpython-ccfdde86eb56b5e24d44e18aa1c276be475aeee2.zip cpython-ccfdde86eb56b5e24d44e18aa1c276be475aeee2.tar.gz cpython-ccfdde86eb56b5e24d44e18aa1c276be475aeee2.tar.bz2 |
Slight reordering of directories searched for BerkDB libs and include files.
Push /usr/... further down the list - always check /usr/local/... before
/usr/...
Doubt this will help with http://python.org/sf/589427 or not, but these
changes were prompted by my investigation of that bug report. I wasn't able
to reproduce that problem though
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 35 |
1 files changed, 23 insertions, 12 deletions
@@ -442,6 +442,7 @@ class PyBuildExt(build_ext): '/usr/local/BerkeleyDB.4.2/lib', '/usr/local/BerkeleyDB.4.1/lib', '/usr/local/BerkeleyDB.4.0/lib', + '/usr/local/lib', '/usr/lib', '/opt/sfw', '/sw/lib', @@ -451,10 +452,10 @@ class PyBuildExt(build_ext): '/usr/local/BerkeleyDB.4.2/include', '/usr/local/BerkeleyDB.4.1/include', '/usr/local/BerkeleyDB.4.0/include', - '/usr/include/db3', + '/usr/local/include/db3', '/opt/sfw/include/db3', '/sw/include/db3', - '/usr/local/include/db3', + '/usr/include/db3', ), 'incs': ('db_185.h',)}, 'db3': {'libs': ('db-3.3', 'db-3.2', 'db-3.1', 'db-3.0'), @@ -462,34 +463,44 @@ class PyBuildExt(build_ext): '/usr/local/BerkeleyDB.3.2/lib', '/usr/local/BerkeleyDB.3.1/lib', '/usr/local/BerkeleyDB.3.0/lib', - '/usr/lib', + '/usr/local/lib', '/opt/sfw', '/sw/lib', + '/usr/lib', '/lib', ), 'incdirs': ('/usr/local/BerkeleyDB.3.3/include', '/usr/local/BerkeleyDB.3.2/include', '/usr/local/BerkeleyDB.3.1/include', '/usr/local/BerkeleyDB.3.0/include', - '/usr/include/db3', + '/usr/local/include/db3', '/opt/sfw/include/db3', '/sw/include/db3', - '/usr/local/include/db3', + '/usr/include/db3', ), 'incs': ('db_185.h',)}, 'db2': {'libs': ('db2',), - 'libdirs': ('/usr/lib', '/sw/lib', '/lib'), - 'incdirs': ('/usr/include/db2', - '/usr/local/include/db2', '/sw/include/db2'), + 'libdirs': ('/usr/local/lib', + '/sw/lib', + '/usr/lib', + '/lib'), + 'incdirs': ('/usr/local/include/db2', + '/sw/include/db2', + '/usr/include/db2'), 'incs': ('db_185.h',)}, # if you are willing to risk hash db file corruption you can # uncomment the lines below for db1. Note that this will affect # not only the bsddb module, but the dbhash and anydbm modules - # as well. you have been warned!!! + # as well. YOU HAVE BEEN WARNED!!! ##'db1': {'libs': ('db1', 'db'), - ## 'libdirs': ('/usr/lib', '/sw/lib', '/lib'), - ## 'incdirs': ('/usr/include/db1', '/usr/local/include/db1', - ## '/usr/include', '/usr/local/include'), + ## 'libdirs': ('/usr/local/lib', + ## '/sw/lib', + ## '/usr/lib', + ## '/lib'), + ## 'incdirs': ('/usr/local/include/db1', + ## '/usr/local/include', + ## '/usr/include/db1', + ## '/usr/include'), ## 'incs': ('db.h',)}, } |