summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBarry Warsaw <barry@python.org>2011-04-07 14:48:29 (GMT)
committerBarry Warsaw <barry@python.org>2011-04-07 14:48:29 (GMT)
commitcece8cfe8a54bb8977ba74599c3861147367a377 (patch)
treef00b1e92cdfc7704bba7b3826f1190780ce93c38 /setup.py
parentff4cd88266b37d266ca607073d9a1122110ef701 (diff)
parent9b5ac3efa64d72b54d4f1ab32a95c260b39ab98d (diff)
downloadcpython-cece8cfe8a54bb8977ba74599c3861147367a377.zip
cpython-cece8cfe8a54bb8977ba74599c3861147367a377.tar.gz
cpython-cece8cfe8a54bb8977ba74599c3861147367a377.tar.bz2
Refinement by Stefan Krah (see issue 11715, msg133194) to exit early if the
dpkg-architecture command is not found on $PATH. This should fix the failures on FreeBSD and Solaris, which do not create the target file via I/O redirection if the command isn't found (unlike Linux and OS X which do).
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index d37bcd0..cbaf1ab 100644
--- a/setup.py
+++ b/setup.py
@@ -373,6 +373,8 @@ class PyBuildExt(build_ext):
def add_multiarch_paths(self):
# Debian/Ubuntu multiarch support.
# https://wiki.ubuntu.com/MultiarchSpec
+ if not find_executable('dpkg-architecture'):
+ return
tmpfile = os.path.join(self.build_temp, 'multiarch')
if not os.path.exists(self.build_temp):
os.makedirs(self.build_temp)