summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlexander Belopolsky <alexander.belopolsky@gmail.com>2010-06-16 22:38:15 (GMT)
committerAlexander Belopolsky <alexander.belopolsky@gmail.com>2010-06-16 22:38:15 (GMT)
commitd95a586d7760731c6c842a1bdfdbb572257bb8ed (patch)
tree252a1a2c0b5165ed85414163a6afa3a70bfb3c6c /setup.py
parent294f27141f170a09916341a8fcc49903b8e4359e (diff)
downloadcpython-d95a586d7760731c6c842a1bdfdbb572257bb8ed.zip
cpython-d95a586d7760731c6c842a1bdfdbb572257bb8ed.tar.gz
cpython-d95a586d7760731c6c842a1bdfdbb572257bb8ed.tar.bz2
Issue #9012: "Separate compilation of time and datetime modules."
Segregated code shared between time and datetime modules into Modules/_time.c. Added a new header file, Modules/_time.h, which will be used instead of Include/timefuncs.h for declarations shared between time and datetime modules.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 18e1cd6..ab7909e 100644
--- a/setup.py
+++ b/setup.py
@@ -450,9 +450,9 @@ class PyBuildExt(build_ext):
depends=['_math.h'],
libraries=math_libs) )
# time operations and variables
- exts.append( Extension('time', ['timemodule.c'],
+ exts.append( Extension('time', ['timemodule.c', '_time.c'],
libraries=math_libs) )
- exts.append( Extension('datetime', ['datetimemodule.c', 'timemodule.c'],
+ exts.append( Extension('datetime', ['datetimemodule.c', '_time.c'],
libraries=math_libs) )
# fast iterator tools implemented in C
exts.append( Extension("itertools", ["itertoolsmodule.c"]) )