diff options
author | Benjamin Peterson <benjamin@python.org> | 2008-05-29 21:09:51 (GMT) |
---|---|---|
committer | Benjamin Peterson <benjamin@python.org> | 2008-05-29 21:09:51 (GMT) |
commit | ebacd26869220b2f300d1b88c59ec3efc60ac00d (patch) | |
tree | 9a1f9a3850fb50f9971fceb633d254e0c8230d1e /setup.py | |
parent | 7dca3ebc97661da9fe2945b9c65d58c234d10629 (diff) | |
download | cpython-ebacd26869220b2f300d1b88c59ec3efc60ac00d.zip cpython-ebacd26869220b2f300d1b88c59ec3efc60ac00d.tar.gz cpython-ebacd26869220b2f300d1b88c59ec3efc60ac00d.tar.bz2 |
add the gestalt module back as _gestalt
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 8 |
1 files changed, 8 insertions, 0 deletions
@@ -1118,6 +1118,14 @@ class PyBuildExt(build_ext): else: missing.append('ossaudiodev') + if sys.platform == 'darwin': + exts.append( + Extension('_gestalt', ['_gestalt.c'], + extra_link_args=['-framework', 'Carbon']) + ) + else: + missing.append('_gestalt') + self.extensions.extend(exts) # Call the method for detecting whether _tkinter can be compiled |