summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2003-01-25 22:41:29 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2003-01-25 22:41:29 (GMT)
commitfc03a94aaccc9ae606ee3438ca21d65a335d43e9 (patch)
tree7aed4887ec4fa6679d1a9baaeb4e2bd5a6c43ece /setup.py
parent5a772d32f4904ffe935d4961e1f23dd359cc3e43 (diff)
downloadcpython-fc03a94aaccc9ae606ee3438ca21d65a335d43e9.zip
cpython-fc03a94aaccc9ae606ee3438ca21d65a335d43e9.tar.gz
cpython-fc03a94aaccc9ae606ee3438ca21d65a335d43e9.tar.bz2
Incorporate Expat 1.95.6.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 3 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 220a7d5..bae3159 100644
--- a/setup.py
+++ b/setup.py
@@ -690,9 +690,9 @@ class PyBuildExt(build_ext):
# More information on Expat can be found at www.libexpat.org.
#
if sys.byteorder == "little":
- xmlbo = "12"
+ xmlbo = "1234"
else:
- xmlbo = "21"
+ xmlbo = "4321"
expatinc = os.path.join(os.getcwd(), srcdir, 'Modules', 'expat')
exts.append(Extension('pyexpat',
sources = [
@@ -702,10 +702,9 @@ class PyBuildExt(build_ext):
'expat/xmltok.c',
],
define_macros = [
- ('HAVE_EXPAT_H',None),
('XML_NS', '1'),
('XML_DTD', '1'),
- ('XML_BYTE_ORDER', xmlbo),
+ ('BYTEORDER', xmlbo),
('XML_CONTEXT_BYTES','1024'),
],
include_dirs = [expatinc]