summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew M. Kuchling <amk@amk.ca>2001-02-27 20:54:23 (GMT)
committerAndrew M. Kuchling <amk@amk.ca>2001-02-27 20:54:23 (GMT)
commit6efc6e783247f54e4dd3b4297a0a7d2bc654a141 (patch)
tree44e8bde777ed899f2589e8ceaa118c0d7b060e60 /setup.py
parent5941d191deaf2a0c8eab5ce75316067ed16dfb1a (diff)
downloadcpython-6efc6e783247f54e4dd3b4297a0a7d2bc654a141.zip
cpython-6efc6e783247f54e4dd3b4297a0a7d2bc654a141.tar.gz
cpython-6efc6e783247f54e4dd3b4297a0a7d2bc654a141.tar.bz2
Patch #404680: disables the nis module and enables the dl module when
building under Cygwin. Makes some fixes to the dlmodule in order to compile with Cygwin.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py13
1 files changed, 7 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 0892f16..f9524e6 100644
--- a/setup.py
+++ b/setup.py
@@ -387,12 +387,13 @@ class PyBuildExt(build_ext):
exts.append( Extension('dl', ['dlmodule.c']) )
# Sun yellow pages. Some systems have the functions in libc.
- if (self.compiler.find_library_file(lib_dirs, 'nsl')):
- libs = ['nsl']
- else:
- libs = []
- exts.append( Extension('nis', ['nismodule.c'],
- libraries = libs) )
+ if platform not in ['cygwin']:
+ if (self.compiler.find_library_file(lib_dirs, 'nsl')):
+ libs = ['nsl']
+ else:
+ libs = []
+ exts.append( Extension('nis', ['nismodule.c'],
+ libraries = libs) )
# Curses support, requring the System V version of curses, often
# provided by the ncurses library.