diff options
author | Martin v. Löwis <martin@v.loewis.de> | 2004-11-13 11:13:35 (GMT) |
---|---|---|
committer | Martin v. Löwis <martin@v.loewis.de> | 2004-11-13 11:13:35 (GMT) |
commit | fba73698240660d9154b6917b87dd333d6fb8284 (patch) | |
tree | 59897e4f17f73a79addb2d778c39f686c126b012 /setup.py | |
parent | deb39b5fef12741d99619f6d25f1af287de883d0 (diff) | |
download | cpython-fba73698240660d9154b6917b87dd333d6fb8284.zip cpython-fba73698240660d9154b6917b87dd333d6fb8284.tar.gz cpython-fba73698240660d9154b6917b87dd333d6fb8284.tar.bz2 |
Patch #1050475: Fix various x86_64 build issues
regrtest.py: skip rgbimg and imageop as they are not built on 64-bit systems.
_tkinter.c: replace %.8x with %p for printing pointers.
setup.py: add lib64 into the library directories.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 5 insertions, 1 deletions
@@ -265,7 +265,10 @@ class PyBuildExt(build_ext): # lib_dirs and inc_dirs are used to search for files; # if a file is found in one of those directories, it can # be assumed that no additional -I,-L directives are needed. - lib_dirs = self.compiler.library_dirs + ['/lib', '/usr/lib', '/usr/lib/lib64'] + lib_dirs = self.compiler.library_dirs + [ + '/lib64', '/usr/lib64', + '/lib', '/usr/lib', + ] inc_dirs = self.compiler.include_dirs + ['/usr/include'] exts = [] @@ -990,6 +993,7 @@ class PyBuildExt(build_ext): added_lib_dirs.append('/usr/openwin/lib') elif os.path.exists('/usr/X11R6/include'): include_dirs.append('/usr/X11R6/include') + added_lib_dirs.append('/usr/X11R6/lib64') added_lib_dirs.append('/usr/X11R6/lib') elif os.path.exists('/usr/X11R5/include'): include_dirs.append('/usr/X11R5/include') |