diff options
author | Gregory P. Smith <greg@mad-scientist.com> | 2006-01-24 10:02:02 (GMT) |
---|---|---|
committer | Gregory P. Smith <greg@mad-scientist.com> | 2006-01-24 10:02:02 (GMT) |
commit | 88f669a757402eb7cb513ef80ea1137089f810ac (patch) | |
tree | aef3b96586ff9aceb1a792395905b9d89ab1595f /setup.py | |
parent | a3b5e99d8d105db0f9b7103900ef501049475e46 (diff) | |
download | cpython-88f669a757402eb7cb513ef80ea1137089f810ac.zip cpython-88f669a757402eb7cb513ef80ea1137089f810ac.tar.gz cpython-88f669a757402eb7cb513ef80ea1137089f810ac.tar.bz2 |
backport of commit 42169
adds support for compiling against BerkeleyDB 4.4.x
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 8 |
1 files changed, 5 insertions, 3 deletions
@@ -485,12 +485,12 @@ class PyBuildExt(build_ext): # Sleepycat Berkeley DB interface. http://www.sleepycat.com # # This requires the Sleepycat DB code. The earliest supported version - # of that library is 3.2, the latest supported version is 4.3. A list + # of that library is 3.2, the latest supported version is 4.4. A list # of available releases can be found at # # http://www.sleepycat.com/update/index.html - max_db_ver = (4, 3) + max_db_ver = (4, 4) min_db_ver = (3, 2) db_setup_debug = False # verbose debug prints from this script? @@ -507,17 +507,19 @@ class PyBuildExt(build_ext): '/sw/include/db3', ] # 4.x minor number specific paths - for x in (0,1,2,3): + for x in (0,1,2,3,4): db_inc_paths.append('/usr/include/db4%d' % x) db_inc_paths.append('/usr/local/BerkeleyDB.4.%d/include' % x) db_inc_paths.append('/usr/local/include/db4%d' % x) db_inc_paths.append('/pkg/db-4.%d/include' % x) + db_inc_paths.append('/opt/db-4.%d/include' % x) # 3.x minor number specific paths for x in (2,3): db_inc_paths.append('/usr/include/db3%d' % x) db_inc_paths.append('/usr/local/BerkeleyDB.3.%d/include' % x) db_inc_paths.append('/usr/local/include/db3%d' % x) db_inc_paths.append('/pkg/db-3.%d/include' % x) + db_inc_paths.append('/opt/db-3.%d/include' % x) db_ver_inc_map = {} |