summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2006-02-11 15:55:22 (GMT)
committerMartin v. Löwis <martin@v.loewis.de>2006-02-11 15:55:22 (GMT)
commitbdba3b6d72810df9ed7600cb5ea469e4199595ce (patch)
tree212b2fd3bbe4b8826a0ddaeda7b406cd19684aa3 /setup.py
parent2fec8b935f524b07d475c3e471197d0391eee235 (diff)
downloadcpython-bdba3b6d72810df9ed7600cb5ea469e4199595ce.zip
cpython-bdba3b6d72810df9ed7600cb5ea469e4199595ce.tar.gz
cpython-bdba3b6d72810df9ed7600cb5ea469e4199595ce.tar.bz2
Patch #428494: Prefer linking against ncursesw over ncurses library
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 4bf0510..7d874cd 100644
--- a/setup.py
+++ b/setup.py
@@ -425,6 +425,9 @@ class PyBuildExt(build_ext):
if self.compiler.find_library_file(lib_dirs, 'readline'):
readline_libs = ['readline']
if self.compiler.find_library_file(lib_dirs,
+ 'ncursesw'):
+ readline_libs.append('ncursesw')
+ elif self.compiler.find_library_file(lib_dirs,
'ncurses'):
readline_libs.append('ncurses')
elif self.compiler.find_library_file(lib_dirs, 'curses'):
@@ -678,7 +681,11 @@ class PyBuildExt(build_ext):
# Curses support, requiring the System V version of curses, often
# provided by the ncurses library.
- if (self.compiler.find_library_file(lib_dirs, 'ncurses')):
+ if (self.compiler.find_library_file(lib_dirs, 'ncursesw')):
+ curses_libs = ['ncursesw']
+ exts.append( Extension('_curses', ['_cursesmodule.c'],
+ libraries = curses_libs) )
+ elif (self.compiler.find_library_file(lib_dirs, 'ncurses')):
curses_libs = ['ncurses']
exts.append( Extension('_curses', ['_cursesmodule.c'],
libraries = curses_libs) )