summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew M. Kuchling <amk@amk.ca>2001-01-17 22:17:16 (GMT)
committerAndrew M. Kuchling <amk@amk.ca>2001-01-17 22:17:16 (GMT)
commit6425efe9aeb27fb698553b4cfcd925517052df72 (patch)
tree31809f7dbf40c7b652d72e1f43760566e828e5d1 /setup.py
parent65e1cea6e372ed809501cf5b927a65c111f79cd3 (diff)
downloadcpython-6425efe9aeb27fb698553b4cfcd925517052df72.zip
cpython-6425efe9aeb27fb698553b4cfcd925517052df72.tar.gz
cpython-6425efe9aeb27fb698553b4cfcd925517052df72.tar.bz2
The signal module has to be compiled statically, so add it to Setup.dist
and remove support for it from setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 0 insertions, 9 deletions
diff --git a/setup.py b/setup.py
index 19c8e0f..9f71592 100644
--- a/setup.py
+++ b/setup.py
@@ -53,14 +53,6 @@ class PyBuildExt(build_ext):
ext.include_dirs.append( '.' ) # to get config.h
ext.include_dirs.append( os.path.join(srcdir, './Include') )
- # If the signal module is being compiled, remove the sigcheck.o and
- # intrcheck.o object files from the archive.
- if module_enabled(self.extensions, 'signal'):
- print 'removing sigcheck.o intrcheck.o'
- ar, library = sysconfig.get_config_vars('AR', 'LIBRARY')
- cmd = '%s d Modules/%s sigcheck.o intrcheck.o' % (ar, library)
- os.system(cmd)
-
build_ext.build_extensions(self)
def detect_modules(self):
@@ -81,7 +73,6 @@ class PyBuildExt(build_ext):
# Some modules that are normally always on:
exts.append( Extension('regex', ['regexmodule.c', 'regexpr.c']) )
exts.append( Extension('pcre', ['pcremodule.c', 'pypcre.c']) )
- exts.append( Extension('signal', ['signalmodule.c']) )
exts.append( Extension('xreadlines', ['xreadlinesmodule.c']) )