diff options
author | Skip Montanaro <skip@pobox.com> | 2003-05-06 20:59:57 (GMT) |
---|---|---|
committer | Skip Montanaro <skip@pobox.com> | 2003-05-06 20:59:57 (GMT) |
commit | 9f5178abb7edd1b1bcaffcdfcf1afd8816dab102 (patch) | |
tree | 3cac36fa0b42a8ecbaf3be122430aef66ed589a6 /setup.py | |
parent | 22e00c42c092c151ab220b234e859d91f5b19c77 (diff) | |
download | cpython-9f5178abb7edd1b1bcaffcdfcf1afd8816dab102.zip cpython-9f5178abb7edd1b1bcaffcdfcf1afd8816dab102.tar.gz cpython-9f5178abb7edd1b1bcaffcdfcf1afd8816dab102.tar.bz2 |
p.strip(os.sep) can't have possibly worked. It would have stripped both
leading and trailing '/' characters on Unix systems.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 2 insertions, 4 deletions
@@ -59,8 +59,7 @@ def find_library_file(compiler, libname, std_dirs, paths): dirname = os.path.dirname(result) for p in std_dirs: # Ensure path doesn't end with path separator - if p.endswith(os.sep): - p = p.strip(os.sep) + p = p.rstrip(os.sep) if p == dirname: return [ ] @@ -68,8 +67,7 @@ def find_library_file(compiler, libname, std_dirs, paths): # so we have to figure out which one. for p in paths: # Ensure path doesn't end with path separator - if p.endswith(os.sep): - p = p.strip(os.sep) + p = p.rstrip(os.sep) if p == dirname: return [p] else: |