diff options
author | Martin v. Löwis <martin@v.loewis.de> | 2004-07-19 16:42:20 (GMT) |
---|---|---|
committer | Martin v. Löwis <martin@v.loewis.de> | 2004-07-19 16:42:20 (GMT) |
commit | 8fbefe28745f980579620147dd0c0fdef94374de (patch) | |
tree | 21a4caa400761ad2aeaca2adb4505e70968f5abd /setup.py | |
parent | b0c319a905132bbeb0737364d405144ce5cdfd60 (diff) | |
download | cpython-8fbefe28745f980579620147dd0c0fdef94374de.zip cpython-8fbefe28745f980579620147dd0c0fdef94374de.tar.gz cpython-8fbefe28745f980579620147dd0c0fdef94374de.tar.bz2 |
Patch #993173: Enable audioop on 64-bit platforms.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 5 |
1 files changed, 4 insertions, 1 deletions
@@ -407,10 +407,13 @@ class PyBuildExt(build_ext): # These don't work for 64-bit platforms!!! # These represent audio samples or images as strings: + # According to #993173, this one should actually work fine on + # 64-bit platforms. + exts.append( Extension('audioop', ['audioop.c']) ) + # Disabled on 64-bit platforms if sys.maxint != 9223372036854775807L: # Operations on audio samples - exts.append( Extension('audioop', ['audioop.c']) ) # Operations on images exts.append( Extension('imageop', ['imageop.c']) ) # Read SGI RGB image files (but coded portably) |