diff options
author | Jack Jansen <jack.jansen@cwi.nl> | 2003-02-24 12:56:36 (GMT) |
---|---|---|
committer | Jack Jansen <jack.jansen@cwi.nl> | 2003-02-24 12:56:36 (GMT) |
commit | 9ce623fce5707c9c2c9c4716d719e4178a08f80b (patch) | |
tree | f364cd89b6a10545e719b8fbd4e488ca66a8ace1 /setup.py | |
parent | 70ec40befa159726dac4969eb6de426bfd6cb88a (diff) | |
download | cpython-9ce623fce5707c9c2c9c4716d719e4178a08f80b.zip cpython-9ce623fce5707c9c2c9c4716d719e4178a08f80b.tar.gz cpython-9ce623fce5707c9c2c9c4716d719e4178a08f80b.tar.bz2 |
That fix was bogus, undone. The problem is that the iconv include file
is found if you are running fink, but the module doesn't work. For now
I disabled building iconv_codec on darwin.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 3 insertions, 3 deletions
@@ -621,9 +621,9 @@ class PyBuildExt(build_ext): ['/usr/local/include', '/usr/pkg/include']) iconv_libs = find_library_file(self.compiler, 'iconv', lib_dirs, ['/usr/local/lib', '/usr/pkg/lib']) - - if iconv_incs: - if iconv_libs: + + if platform not in ['darwin'] and iconv_incs is not None: + if iconv_libs is not None: iconv_libraries = ['iconv'] else: iconv_libraries = [] # in libc |