summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2003-12-03 22:34:19 (GMT)
committerJack Jansen <jack.jansen@cwi.nl>2003-12-03 22:34:19 (GMT)
commitfe3fe4adb5c7a72bfec3c5b7b8ec5e42d8ccc625 (patch)
tree78b64ad4523e884ed7e33ad0df90e16696f003ed /setup.py
parent8850c8785f9b61e9d2b4803a0249d0ae20d932fd (diff)
downloadcpython-fe3fe4adb5c7a72bfec3c5b7b8ec5e42d8ccc625.zip
cpython-fe3fe4adb5c7a72bfec3c5b7b8ec5e42d8ccc625.tar.gz
cpython-fe3fe4adb5c7a72bfec3c5b7b8ec5e42d8ccc625.tar.bz2
Adding an interface to the high-level Open Scripting Architecture,
by request of Donovan Preston. In return, he promised to use this to create a Python OSA component, which would turn Python into a first-class OSA scripting language (like AppleScript itself).
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 8c75ddc..2c3eae6 100644
--- a/setup.py
+++ b/setup.py
@@ -836,6 +836,8 @@ class PyBuildExt(build_ext):
extra_link_args=['-framework', 'Carbon']) )
exts.append( Extension('_Mlte', ['mlte/_Mltemodule.c'],
extra_link_args=['-framework', 'Carbon']) )
+ exts.append( Extension('_OSA', ['osa/_OSAmodule.c'],
+ extra_link_args=['-framework', 'Carbon']) )
exts.append( Extension('_Qd', ['qd/_Qdmodule.c'],
extra_link_args=['-framework', 'Carbon']) )
exts.append( Extension('_Qdoffs', ['qdoffs/_Qdoffsmodule.c'],