diff options
author | Guido van Rossum <guido@python.org> | 2003-02-20 02:11:43 (GMT) |
---|---|---|
committer | Guido van Rossum <guido@python.org> | 2003-02-20 02:11:43 (GMT) |
commit | 12471d63893f84cb88deccf83af5aa5c6866c275 (patch) | |
tree | 19bda5140b1d4b882cd03bc7b40bb69bf7ac8c62 /setup.py | |
parent | af160659184f1d551621c70b2979ce5ce56e7fff (diff) | |
download | cpython-12471d63893f84cb88deccf83af5aa5c6866c275.zip cpython-12471d63893f84cb88deccf83af5aa5c6866c275.tar.gz cpython-12471d63893f84cb88deccf83af5aa5c6866c275.tar.bz2 |
Don't use self.announce() in a function that's not a method.
Use level=3 (i.e. log.WARN) for the warnings about failed imports.
(Hmm... Why is that code in an "if 1: ..."? What's the else branch
for?)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 3 insertions, 3 deletions
@@ -88,7 +88,7 @@ def find_module_file(module, dirlist): if not list: return module if len(list) > 1: - self.announce("WARNING: multiple copies of %s found"%module) + log.info("WARNING: multiple copies of %s found"%module) return os.path.join(list[0], module) class PyBuildExt(build_ext): @@ -211,7 +211,7 @@ class PyBuildExt(build_ext): if 1: self.announce('*** WARNING: renaming "%s" since importing it' - ' failed: %s' % (ext.name, why)) + ' failed: %s' % (ext.name, why), level=3) assert not self.inplace basename, tail = os.path.splitext(ext_filename) newname = basename + "_failed" + tail @@ -231,7 +231,7 @@ class PyBuildExt(build_ext): self.announce('unable to remove files (ignored)') else: self.announce('*** WARNING: importing extension "%s" ' - 'failed: %s' % (ext.name, why)) + 'failed: %s' % (ext.name, why), level=3) def get_platform (self): # Get value of sys.platform |