summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJesse Noller <jnoller@gmail.com>2008-09-30 00:15:45 (GMT)
committerJesse Noller <jnoller@gmail.com>2008-09-30 00:15:45 (GMT)
commit37040cdace1982772e5f35e4acfa13861d72065d (patch)
tree07b4887aaac30870277beb6afe45a1e5652ed539 /setup.py
parente563aa4383df36cefe5c85c2a85b9008f54df048 (diff)
downloadcpython-37040cdace1982772e5f35e4acfa13861d72065d.zip
cpython-37040cdace1982772e5f35e4acfa13861d72065d.tar.gz
cpython-37040cdace1982772e5f35e4acfa13861d72065d.tar.bz2
issue3770: if SEM_OPEN is 0, disable the mp.synchronize module, rev. Nick Coghlan, Damien Miller
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 8 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index f979a29..4b23186 100644
--- a/setup.py
+++ b/setup.py
@@ -1269,6 +1269,14 @@ class PyBuildExt(build_ext):
)
libraries = []
+ elif platform.startswith('openbsd'):
+ macros = dict( # OpenBSD
+ HAVE_SEM_OPEN=0, # Not implemented
+ HAVE_SEM_TIMEDWAIT=0,
+ HAVE_FD_TRANSFER=1,
+ )
+ libraries = []
+
else: # Linux and other unices
macros = dict(
HAVE_SEM_OPEN=1,