summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorGregory P. Smith <greg@mad-scientist.com>2007-10-09 06:02:21 (GMT)
committerGregory P. Smith <greg@mad-scientist.com>2007-10-09 06:02:21 (GMT)
commit392505391e1703fe0df4da8e077793f7e71b1075 (patch)
treed9d44180ad00b886cfbbf952883fbe3e674190fb /setup.py
parent163f622c03487a747f89b4359663a8ce52b57f81 (diff)
downloadcpython-392505391e1703fe0df4da8e077793f7e71b1075.zip
cpython-392505391e1703fe0df4da8e077793f7e71b1075.tar.gz
cpython-392505391e1703fe0df4da8e077793f7e71b1075.tar.bz2
Splits Modules/_bsddb.c up into bsddb.h and _bsddb.c and adds a C API
object available as bsddb.db.api. This is based on the patch submitted by Duncan Grisby here: http://sourceforge.net/tracker/index.php?func=detail&aid=1551895&group_id=13900&atid=313900 See this thread for additional info: http://sourceforge.net/mailarchive/forum.php?thread_name=E1GAVDK-0002rk-Iw%40apasphere.com&forum_name=pybsddb-users It also cleans up the code a little by removing some ifdef/endifs for python prior to 2.1 and for unsupported Berkeley DB <= 3.2.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 6df10cc..09c7b4c 100644
--- a/setup.py
+++ b/setup.py
@@ -801,6 +801,7 @@ class PyBuildExt(build_ext):
# some unusual system configurations (e.g. the directory
# is on an NFS server that goes away).
exts.append(Extension('_bsddb', ['_bsddb.c'],
+ depends = ['bsddb.h'],
library_dirs=dblib_dir,
runtime_library_dirs=dblib_dir,
include_dirs=db_incs,