summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorEric Smith <eric@trueblade.com>2008-02-23 03:09:44 (GMT)
committerEric Smith <eric@trueblade.com>2008-02-23 03:09:44 (GMT)
commita73fbe791d0d41db543ebe39d2f6df0a4265be4b (patch)
treea07f32dc9b4de83ec186ee8a06430230edba48c3 /setup.py
parent73d796324242dc2164a0b5943bd08d6252a28651 (diff)
downloadcpython-a73fbe791d0d41db543ebe39d2f6df0a4265be4b.zip
cpython-a73fbe791d0d41db543ebe39d2f6df0a4265be4b.tar.gz
cpython-a73fbe791d0d41db543ebe39d2f6df0a4265be4b.tar.bz2
Added future_builtins, which contains PEP 3127 compatible versions of hex() and oct().
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 4bc6f8c..c643845 100644
--- a/setup.py
+++ b/setup.py
@@ -417,6 +417,9 @@ class PyBuildExt(build_ext):
libraries=math_libs) )
exts.append( Extension('datetime', ['datetimemodule.c', 'timemodule.c'],
libraries=math_libs) )
+ # code that will be builtins in the future, but conflict with the
+ # current builtins
+ exts.append( Extension('future_builtins', ['future_builtins.c']) )
# random number generator implemented in C
exts.append( Extension("_random", ["_randommodule.c"]) )
# fast iterator tools implemented in C