summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorGregory P. Smith <greg@mad-scientist.com>2007-09-10 16:36:32 (GMT)
committerGregory P. Smith <greg@mad-scientist.com>2007-09-10 16:36:32 (GMT)
commitf3d280e62acfa2d597dff13105f7fec4a5eeb8e6 (patch)
tree100b5a3258a2276d890435e41d2e4a396ae04947 /setup.py
parent342cff6d555e7ab6833ea52178b4662e4a5738e8 (diff)
downloadcpython-f3d280e62acfa2d597dff13105f7fec4a5eeb8e6.zip
cpython-f3d280e62acfa2d597dff13105f7fec4a5eeb8e6.tar.gz
cpython-f3d280e62acfa2d597dff13105f7fec4a5eeb8e6.tar.bz2
Don't allow BerkeleyDB 4.6.x as the current 4.6.19 release is prone
to lockups. We'll reenable it once a good 4.6.x release exists.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 3672e6d..1a7ce26 100644
--- a/setup.py
+++ b/setup.py
@@ -663,7 +663,9 @@ class PyBuildExt(build_ext):
# a release. Most open source OSes come with one or more
# versions of BerkeleyDB already installed.
- max_db_ver = (4, 6)
+ # XXX(gps) - Do not allow BerkeleyDB 4.6.x until Oracle fixes
+ # the DB_HASH lockup bug that is present in 4.6.19.
+ max_db_ver = (4, 5)
min_db_ver = (3, 3)
db_setup_debug = False # verbose debug prints from this script?
@@ -681,7 +683,7 @@ class PyBuildExt(build_ext):
'/sw/include/db3',
]
# 4.x minor number specific paths
- for x in (0,1,2,3,4,5,6):
+ for x in range(max_db_ver[1]+1):
db_inc_paths.append('/usr/include/db4%d' % x)
db_inc_paths.append('/usr/include/db4.%d' % x)
db_inc_paths.append('/usr/local/BerkeleyDB.4.%d/include' % x)