summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorGregory P. Smith <greg@mad-scientist.com>2008-01-28 23:21:00 (GMT)
committerGregory P. Smith <greg@mad-scientist.com>2008-01-28 23:21:00 (GMT)
commitf866bac73c6a6f6a15ef2217cb5ac9f3160a9378 (patch)
treeb3d01c2e3f6f054e344b24a1d15fab8504e4f7a2 /setup.py
parentbf3d1d5dc8ef84c2ef43c7785d3caa2b82f32d20 (diff)
downloadcpython-f866bac73c6a6f6a15ef2217cb5ac9f3160a9378.zip
cpython-f866bac73c6a6f6a15ef2217cb5ac9f3160a9378.tar.gz
cpython-f866bac73c6a6f6a15ef2217cb5ac9f3160a9378.tar.bz2
Disable use of BerkeleyDB 4.6.x to see what the odd platform buildbots
think. In particular, neal norwitz has traced an Ubuntu sparc64 crash to the Lib/test/bsddb/test_basics.py test when opening a db with DB_THREAD.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 8b850c5..51ef16b 100644
--- a/setup.py
+++ b/setup.py
@@ -681,7 +681,10 @@ class PyBuildExt(build_ext):
# a release. Most open source OSes come with one or more
# versions of BerkeleyDB already installed.
- max_db_ver = (4, 6)
+ max_db_ver = (4, 5) # XXX(gregory.p.smith): 4.6 "works" but seems to
+ # have issues on many platforms. I've temporarily
+ # disabled 4.6 to see what the odd platform
+ # buildbots say.
min_db_ver = (3, 3)
db_setup_debug = False # verbose debug prints from this script?