diff options
author | Jack Jansen <jack.jansen@cwi.nl> | 2003-02-24 12:48:58 (GMT) |
---|---|---|
committer | Jack Jansen <jack.jansen@cwi.nl> | 2003-02-24 12:48:58 (GMT) |
commit | 70ec40befa159726dac4969eb6de426bfd6cb88a (patch) | |
tree | cb2450a126cabb171cb351886a08372caea0f4de /setup.py | |
parent | deac2acdb8865a88fdc6a318e7967ba60f7d7e75 (diff) | |
download | cpython-70ec40befa159726dac4969eb6de426bfd6cb88a.zip cpython-70ec40befa159726dac4969eb6de426bfd6cb88a.tar.gz cpython-70ec40befa159726dac4969eb6de426bfd6cb88a.tar.bz2 |
The test for iconv_incs tested explicitly for None, but [] is returned
if the include files cannot be found.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 4 |
1 files changed, 2 insertions, 2 deletions
@@ -622,8 +622,8 @@ class PyBuildExt(build_ext): iconv_libs = find_library_file(self.compiler, 'iconv', lib_dirs, ['/usr/local/lib', '/usr/pkg/lib']) - if (iconv_incs is not None): - if iconv_libs is not None: + if iconv_incs: + if iconv_libs: iconv_libraries = ['iconv'] else: iconv_libraries = [] # in libc |