summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMatthias Klose <doko@ubuntu.com>2006-04-03 16:27:50 (GMT)
committerMatthias Klose <doko@ubuntu.com>2006-04-03 16:27:50 (GMT)
commit8e39ec78bcede7291e0573fc522425221eb05475 (patch)
treecffbc431361f47a0d797ba7f3f7dd3189bb232fa /setup.py
parentdb5483be64c59edd743d69e601a1e990c4576ec7 (diff)
downloadcpython-8e39ec78bcede7291e0573fc522425221eb05475.zip
cpython-8e39ec78bcede7291e0573fc522425221eb05475.tar.gz
cpython-8e39ec78bcede7291e0573fc522425221eb05475.tar.bz2
- Patch #360466: Replace the MD5 implementation from RSA Data Security Inc
with the implementation from http://sourceforge.net/projects/libmd5-rfc/.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 1a0ae87..affa20a 100644
--- a/setup.py
+++ b/setup.py
@@ -549,8 +549,8 @@ class PyBuildExt(build_ext):
exts.append( Extension('_sha', ['shamodule.c']) )
# The _md5 module implements the RSA Data Security, Inc. MD5
# Message-Digest Algorithm, described in RFC 1321. The
- # necessary files md5c.c and md5.h are included here.
- exts.append( Extension('_md5', ['md5module.c', 'md5c.c']) )
+ # necessary files md5.c and md5.h are included here.
+ exts.append( Extension('_md5', ['md5module.c', 'md5.c']) )
if (openssl_ver < 0x00908000):
# OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash