summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Heller <theller@ctypes.org>2008-05-20 19:53:47 (GMT)
committerThomas Heller <theller@ctypes.org>2008-05-20 19:53:47 (GMT)
commit03b75ddf7c63bb7b7bc1b424661c94076b57be9e (patch)
tree8dfbbc2c4c42ee32f987eafdfd0d29dd8cfbac65 /setup.py
parentc01288387c47a75cab059a6d0c6dfe4cb9eff2de (diff)
downloadcpython-03b75ddf7c63bb7b7bc1b424661c94076b57be9e.zip
cpython-03b75ddf7c63bb7b7bc1b424661c94076b57be9e.tar.gz
cpython-03b75ddf7c63bb7b7bc1b424661c94076b57be9e.tar.bz2
On HPUX, -fPIC must be used for linking. _ctypes now builds on HP-UX
IA64 and PA machines. The ctypes unittests work fine on the IA64, but dump core in test_qsort on the PA.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 34035ed..4663cec 100644
--- a/setup.py
+++ b/setup.py
@@ -1580,6 +1580,9 @@ class PyBuildExt(build_ext):
# finding some -z option for the Sun compiler.
extra_link_args.append('-mimpure-text')
+ elif sys.platform.startswith('hpux'):
+ extra_link_args.append('-fPIC')
+
ext = Extension('_ctypes',
include_dirs=include_dirs,
extra_compile_args=extra_compile_args,