diff options
author | Michael W. Hudson <mwh@python.net> | 2002-03-07 09:58:56 (GMT) |
---|---|---|
committer | Michael W. Hudson <mwh@python.net> | 2002-03-07 09:58:56 (GMT) |
commit | 0c46c0cc70613c34862513a2c8d679128146e90e (patch) | |
tree | dd1e60fe824a9904252f4489aaa5c69fc1597a77 /setup.py | |
parent | 02b28ec316114a646c7875a76edeb577c5c3581b (diff) | |
download | cpython-0c46c0cc70613c34862513a2c8d679128146e90e.zip cpython-0c46c0cc70613c34862513a2c8d679128146e90e.tar.gz cpython-0c46c0cc70613c34862513a2c8d679128146e90e.tar.bz2 |
Apply Jack's patch attached to
[ 508779 ] Disable flat namespace on MacOS X
I presume you wanted this on the trunk too, Jack?
2.2.1 candidate.
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 9 |
1 files changed, 6 insertions, 3 deletions
@@ -604,7 +604,8 @@ class PyBuildExt(build_ext): # available here. This Makefile variable is also what the install # procedure triggers on. frameworkdir = sysconfig.get_config_var('PYTHONFRAMEWORKDIR') - exts.append( Extension('gestalt', ['gestaltmodule.c']) ) + exts.append( Extension('gestalt', ['gestaltmodule.c'], + extra_link_args=['-framework', 'Carbon']) ) exts.append( Extension('MacOS', ['macosmodule.c'], extra_link_args=['-framework', 'Carbon']) ) exts.append( Extension('icglue', ['icgluemodule.c'], @@ -613,8 +614,10 @@ class PyBuildExt(build_ext): ['macfsmodule.c', '../Python/getapplbycreator.c'], extra_link_args=['-framework', 'Carbon']) ) - exts.append( Extension('_CF', ['cf/_CFmodule.c']) ) - exts.append( Extension('_Res', ['res/_Resmodule.c']) ) + exts.append( Extension('_CF', ['cf/_CFmodule.c'], + extra_link_args=['-framework', 'CoreFoundation']) ) + exts.append( Extension('_Res', ['res/_Resmodule.c'], + extra_link_args=['-framework', 'Carbon']) ) exts.append( Extension('_Snd', ['snd/_Sndmodule.c'], extra_link_args=['-framework', 'Carbon']) ) if frameworkdir: |