summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorFred Drake <fdrake@acm.org>2002-06-04 15:28:21 (GMT)
committerFred Drake <fdrake@acm.org>2002-06-04 15:28:21 (GMT)
commit16c8d702a41c2de20484e88030fa12b82d6322de (patch)
treef8670bc7f10d0c61c2f166d1bc129f64394cdc18 /setup.py
parent474458da4894b542ff63fb8eaafeaefad7744005 (diff)
downloadcpython-16c8d702a41c2de20484e88030fa12b82d6322de.zip
cpython-16c8d702a41c2de20484e88030fa12b82d6322de.tar.gz
cpython-16c8d702a41c2de20484e88030fa12b82d6322de.tar.bz2
When using a Python that has not been installed to build 3rd-party
modules, distutils does not understand that the build version of the source tree is needed. This patch fixes distutils.sysconfig to understand that the running Python is part of the build tree and needs to use the appropriate "shape" of the tree. This does not assume anything about the current directory, so can be used to build 3rd-party modules using Python's build tree as well. This is useful since it allows us to use a non-installed debug-mode Python with 3rd-party modules for testing. It as the side-effect that set_python_build() is no longer needed (the hack which was added to allow distutils to be used to build the "standard" extension modules). This closes SF patch #547734.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 0 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index d2b3947..929f2e6 100644
--- a/setup.py
+++ b/setup.py
@@ -822,5 +822,4 @@ def main():
# --install-platlib
if __name__ == '__main__':
- sysconfig.set_python_build()
main()