summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Wouters <thomas@python.org>2008-04-05 23:39:15 (GMT)
committerThomas Wouters <thomas@python.org>2008-04-05 23:39:15 (GMT)
commit2fab8f1abb1c5d51cfe3bbdc7a912e7c574ccf46 (patch)
treebece48e9859ee2f09b9d594d9b084e54d262d76e /setup.py
parent9e0fa7a13ec3c4381ffa5d9b6f745415fc570d29 (diff)
downloadcpython-2fab8f1abb1c5d51cfe3bbdc7a912e7c574ccf46.zip
cpython-2fab8f1abb1c5d51cfe3bbdc7a912e7c574ccf46.tar.gz
cpython-2fab8f1abb1c5d51cfe3bbdc7a912e7c574ccf46.tar.bz2
Fix test_distutils to not fail when running 'make test' from a Python build
directory that is not the source directory (ie, one created using '/path/to/source/configure'.) Leaves this test very slightly degraded in that particular case, compared to the build-in-sourcedir case, but that case isn't a particularly strong test either: neither test the actual path that will be used after installing. There isn't a particularly good way to test this, and a poor test beats a failing test.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index af15855..5df8124 100644
--- a/setup.py
+++ b/setup.py
@@ -119,6 +119,8 @@ class PyBuildExt(build_ext):
raise ValueError("No source directory; cannot proceed.")
# Figure out the location of the source code for extension modules
+ # (This logic is copied in distutils.test.test_sysconfig,
+ # so building in a separate directory does not break test_distutils.)
moddir = os.path.join(os.getcwd(), srcdir, 'Modules')
moddir = os.path.normpath(moddir)
srcdir, tail = os.path.split(moddir)