diff options
author | Jesse Noller <jnoller@gmail.com> | 2008-09-30 00:15:45 (GMT) |
---|---|---|
committer | Jesse Noller <jnoller@gmail.com> | 2008-09-30 00:15:45 (GMT) |
commit | 37040cdace1982772e5f35e4acfa13861d72065d (patch) | |
tree | 07b4887aaac30870277beb6afe45a1e5652ed539 /setup.py | |
parent | e563aa4383df36cefe5c85c2a85b9008f54df048 (diff) | |
download | cpython-37040cdace1982772e5f35e4acfa13861d72065d.zip cpython-37040cdace1982772e5f35e4acfa13861d72065d.tar.gz cpython-37040cdace1982772e5f35e4acfa13861d72065d.tar.bz2 |
issue3770: if SEM_OPEN is 0, disable the mp.synchronize module, rev. Nick Coghlan, Damien Miller
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 8 |
1 files changed, 8 insertions, 0 deletions
@@ -1269,6 +1269,14 @@ class PyBuildExt(build_ext): ) libraries = [] + elif platform.startswith('openbsd'): + macros = dict( # OpenBSD + HAVE_SEM_OPEN=0, # Not implemented + HAVE_SEM_TIMEDWAIT=0, + HAVE_FD_TRANSFER=1, + ) + libraries = [] + else: # Linux and other unices macros = dict( HAVE_SEM_OPEN=1, |